Skip to content
Open
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension


Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
5 changes: 5 additions & 0 deletions .changeset/dependencies-GH-271.md
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
---
"@portabletext/react-native": patch
---

fix(deps): update dependency react-native to v0.88.1
4 changes: 2 additions & 2 deletions package.json
Original file line number Diff line number Diff line change
Expand Up @@ -93,14 +93,14 @@
"jest": "^30.2.0",
"prettier": "^3.7.4",
"react": "^19.2.3",
"react-native": "^0.85.1",
"react-native": "^0.88.1",

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

React version incompatible with React Native

Medium Severity

react-native 0.88.1 requires react ^19.3.0, but react and react-test-renderer stay on ^19.2.3. The lockfile now installs both scheduler 0.27.0 and 0.28.0, so installs warn and tests can render against an unsupported pairing.

Fix in Cursor Fix in Web

Reviewed by Cursor Bugbot for commit ccf5d3a. Configure here.

"react-native-builder-bob": "^0.40.17",
"react-test-renderer": "^19.2.3",
"typescript": "5.9.3"
},
"peerDependencies": {
"react": "^18.2 || ^19",
"react-native": "^0.74 || ^0.75 || ^0.76 || ^0.77 || ^0.78 || ^0.79 || ^0.80 || ^0.81 || ^0.82.0 || ^0.83.0 || ^0.84.0 || ^0.85.0"
"react-native": "^0.74 || ^0.75 || ^0.76 || ^0.77 || ^0.78 || ^0.79 || ^0.80 || ^0.81 || ^0.82.0 || ^0.83.0 || ^0.84.0 || ^0.85.0 || ^0.88.0"
},
"packageManager": "pnpm@10.27.0",
"publishConfig": {
Expand Down
Loading
Loading