Skip to content
Open
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension


Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
2 changes: 1 addition & 1 deletion .github/workflows/deploy.yml
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@ jobs:
- run: pnpm install
- run: pnpm build
- run: pnpm docs:build
- uses: peaceiris/actions-gh-pages@4f9cc6602d3f66b9c108549d475ec49e8ef4d45e # v4
- uses: peaceiris/actions-gh-pages@84c30a85c19949d7eee79c4ff27748b70285e453 # v4
with:
github_token: ${{ steps.generate-token.outputs.token }}
publish_dir: ./docs
18 changes: 9 additions & 9 deletions package.json
Original file line number Diff line number Diff line change
Expand Up @@ -45,15 +45,15 @@
"test": "pnpm run node:test"
},
"devDependencies": {
"@changesets/changelog-github": "^0.5.2",
"@changesets/cli": "^2.29.8",
"@sanity/tsconfig": "^2.1.0",
"@sanity/tsdown-config": "^0.5.8",
"oxfmt": "^0.36.0",
"oxlint": "^1.51.0",
"oxlint-tsgolint": "^0.16.0",
"tsdown": "^0.20.3",
"typedoc": "^0.28.17",
"@changesets/changelog-github": "^0.7.0",
"@changesets/cli": "^2.31.1",
"@sanity/tsconfig": "^2.2.1",
"@sanity/tsdown-config": "^0.31.2",

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

TypeScript peer range no longer satisfied

Medium Severity

@sanity/tsdown-config 0.31.2 requires a typescript peer of 6.x or 7.x, but the repo still pins 5.9.3. That pairing is unsupported and can break defineConfig types or the tsdown build.

Fix in Cursor Fix in Web

Reviewed by Cursor Bugbot for commit 742fee3. Configure here.

"oxfmt": "^0.74.0",
"oxlint": "^1.89.0",
"oxlint-tsgolint": "^0.25.0",

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Incompatible oxlint-tsgolint peer version

High Severity

oxlint 1.89.0 requires oxlint-tsgolint >=7.0.2003, but this update leaves oxlint-tsgolint at 0.25.0. The lint script uses --type-aware --type-check, so type-aware linting can fail or skip those rules in CI.

Fix in Cursor Fix in Web

Reviewed by Cursor Bugbot for commit cb03396. Configure here.

"tsdown": "^0.23.2",
"typedoc": "^0.28.20",
"typescript": "5.9.3"
},
"lint-staged": {
Expand Down
Loading
Loading